26 января 2015

Штатный пакет брокера RabbitMQ в составе дистрибутива Astra Linux Special Edition страдает двумя врожденными проблемами:

  1. Дефектный скрипт запуска /etc/init.d/rabbitmq-server (#56 на багтрекере Астры). В силу спорных изменений русбитеховцами в /etc/default/rcS, упомянутый скрипт не работает. Что, в свою очередь,
    приводит к фатальным последствиям в виде невозможности установить и сам пакет.
  2. Поставляемые стандартные скрипты не могут запускать RabbitMQ сервер с механизмом privsock. Прощай подключения к брокеру от секретных процессов.

Поэтому мы создали пакет rabbitmq-server-parsec, который все это исправляет. Он не является заменой штатному rabbitmq-server, а предоставляет альтернативный демон rabbitmq-server-parsec. Все что он делает — запускает брокер RabbitMQ с привилегией privsock.

Плюс, если вы будете устанавливать этот пакет вместо rabbitmq-server, он подтянет последний по зависимостям и установит его правильно.

Собранный пакет находится в нашем репозитории.

0 комментариев

Что у нас
нового

Блог

Репозиторий с обновлениями безопасности Astra Linux Special Edition

Лаборатория 50 на протяжении 5 лет поддерживает репозиторий с обновлениями безопасности Astra Linux Special Edition.

«Моно» для Astra Linux Special Edition 1.7

2 марта 2022

Выпущена версия программного комплекса «Моно» для Astra Linux Special Edition 1.7. 

Наши
контакты

Связаться с нами

Телефон 8 (812) 981-68-09
Электронная почта team@lab50.net





    Заполняя данную форму, вы принимаете условия Соглашения об использовании сайта, и соглашаетесь
    с Правилами обработки и использования персональных данных